SignRequest affected by AWS downtime
Incident Report for SignRequest
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 18:34 CET
Monitoring
AWS connectivity is coming back
Posted Dec 15, 2021 - 17:22 CET
Investigating
We are currently investigating this issue.
Posted Dec 15, 2021 - 17:02 CET
This incident affected: API, Web app, and Workers.